1. We are currently experiencing issues with viewing and uploading images, our team is working on the issue.
    Dismiss Notice

I have WPM starting.....

Discussion in 'Marijuana Plant Problems' started by Danthegrowinman77, Sep 10, 2017.

  1.  
    Danthegrowinman77

    Danthegrowinman77 Member

    20170910_194810.jpg Went to the crop tonight and notices a few leaves on my plants have white powdery mildew. You can see it in that pic on some leaves. how can I effectively treat this. I'm into my 5th week of flower so don't wanna use neem oil or should I?
     
  2.  
    macsnax

    macsnax Well-Known Member

    I think @vostok would know about using neem or not.
     
    vostok likes this.
  3.  
    Diabolical666

    Diabolical666 Well-Known Member

    Green Cure
     
  4.  
    Sir Napsalot

    Sir Napsalot Well-Known Member

    I'd spray it with 3% hydrogen peroxide
     
    Nugachino likes this.
  5.  
    vostok

    vostok Well-Known Member

    Its no biggy

    WPM is an annoyance

    as Mac^^^ says I wouldn't hesitate to spray some cold pressed neem oil

    the effects will be long gone by harvest (taste and smell)

    tho the WPM is telling you fungi are active and Queen Bitch is on her way(Pythium)

    also called bud rot, etc etc

    I'd be cutting a breeze way thru that forest

    to get the wind to dry the plant out quicker

    good luck
     
  6.  
    Danthegrowinman77

    Danthegrowinman77 Member

    That's exactly what I did vostok. Thinned out the plants and the WPM is gone :)
     
    vostok and Roger A. Shrubber like this.
  7.  
    joken

    joken Well-Known Member

    Green cure
     
  8.  
    Danthegrowinman77

    Danthegrowinman77 Member

  9.  
    Danthegrowinman77

    Danthegrowinman77 Member

Share This Page