Can anyone tell me about this light? Is it suitable?

Shit guys the bulb is not working today. It went on but not very bright then i tried again and it did not go on. This happened once before but it just started working again. wtf!
Can this bulb be used as replacement for this lamp?
 

getogrow

Well-Known Member
Shit guys the bulb is not working today. It went on but not very bright then i tried again and it did not go on. This happened once before but it just started working again. wtf!
Can this bulb be used as replacement for this lamp?
yes that bulb will work. the "big"base is a e39 mogul base. any 400 watt MH will work.
 
can you find any stickers at all on that fixture?
The bulb would not get bright once a month ago. Other than that its been fine for 2 months. Yes there are stickers and it seems this correct bulb. The new one dont light at all. The old one lights but dont get bright like before
 

getogrow

Well-Known Member
The bulb would not get bright once a month ago. Other than that its been fine for 2 months. Yes there are stickers and it seems this correct bulb. The new one dont light at all. The old one lights but dont get bright like before
i wasnt questioning the bulb fitting. Im giving you more credit then that sir ! I just wanna make sure its wired for 120vac and see if there are any clues as to why its doing that.
So it lights up but thats all ? it never gets bright? It did this when you first got it with the same bulb an then it started working fine. again with the same bulb. New bulb wont even light at all ? hmmm
im thinking the capacitor is bad in your ballast. if you are bored , you can tear it apart an fix it super cheap.
 
i wasnt questioning the bulb fitting. Im giving you more credit then that sir ! I just wanna make sure its wired for 120vac and see if there are any clues as to why its doing that.
So it lights up but thats all ? it never gets bright? It did this when you first got it with the same bulb an then it started working fine. again with the same bulb. New bulb wont even light at all ? hmmm
im thinking the capacitor is bad in your ballast. if you are bored , you can tear it apart an fix it super cheap.
Shit look the bottom is different. It cant reach the bottom cuz it hits the plastic wtf lol Can I unscrew that and put washers to raise it up? It that ok?

 
with everything unplugged , reach down in there and pry that prong up a tad. they bend easy , they dont break easy though. I do that with every bulb holder in my home when i replace them. (im an electrician so i like good connections)
Thanks bro. I got it working!!!
I had to unscrew the center button and put a longer screw with washers and a new spring to lift it above that round plastic. So now I guess new light can reach the connection.
 
>
Top