Nute problem

greenforce

Active Member
Hey fellow growers
I have nute problem please help me diagnose it. Two Blue widow by dinafem, I think its nitrogen problem on the first plant and dont know about second. They are 28days old under 400w hps and gave them biobizz grow 3 times in period of 3 weeks, here are the pictures... First picture is leaf from first plant and the rest is from second.
 

Attachments

Dr. Who

Well-Known Member
If you don't use a Ca/Mg product - start.

Those are the the lowest leaf sets on the main stem. They will "self prune" as the plant grows from time to time.
Don't sweat it!

Biobizz eh?

I see lots of high P problems around here with that.....Do your self a favor and when you get to the point where you flip the plant to 12/12 ( I like 11/13 FAR better). DO NOT start ANY bloom food for 2 weeks! KEEP using the veg food! Then at week 3 mix the veg and bloom 50/50 for a week and THEN go full strength bloom nutes..
 

PerfectGrower

Well-Known Member
Dr. Who is correct...keep that P on the lower side, especially during the plant's transition into flowering. High P will cause the plant to stretch. If you'd like, you can increase the P week 3 of flower. High P is surely not necessary for a huge healthy plant. We recommend around 80-90PPM of P during the mid to late flowering stage.



Some boosters can get your P values well above 100. Be careful.
 

greenforce

Active Member
Thanks guys for fast replies i will keep your advices in mind. Another thing happened on my 3 plant and i see that its starting on my other two plants please look at this pictures...
 

Attachments

>
Top